Java Static Initializer Block- HackerRank Solution

0

Static initialization blocks are executed when the class is loaded, and you can initialize static variables in those blocks.




You are given a class Solution with a main method. Complete the given code so that it outputs the area of a parallelogram with breadth B and height H . You should read the variables from the standard input.


If B<=0 or H<=0 , the output should be "java.lang.Exception: Breadth and height must be positive" without quotes.


Input Format


There are two lines of input. The first line contains B: the breadth of the parallelogram. The next line contains H : the height of the parallelogram.


Constraints


 -100<=B<=100

 -100<=H<=100


Output Format


If both values are greater than zero, then the main method must output the area of the parallelogram. Otherwise, print "java.lang.Exception: Breadth and height must be positive" without quotes.


Sample input 1


1

3


Sample output 1


3


Sample input 2


-1

2


Sample output 2


java.lang.Exception: Breadth and height must be positive

 

Solution


 import java.io.*;
 import java.util.*;
 import java.text.*;
 import java.math.*;
 import java.util.regex.*;

 public class Solution {

 static int B;
 static int H;
 static boolean flag=false;
 static{
 Scanner sc=new Scanner(System.in);
 B=sc.nextInt();
 H=sc.nextInt();
 flag=false;
 if( H <= 0 || B <= 0){
 System.out.println("java.lang.Exception: Breadth and height must be positive");
 }
 else{
 flag=true;
  }
 }


 public static void main(String[] args){
 if(flag){
 int area=B*H;
 System.out.print(area);
  }

  }//end of main

 }//end of class



Post a Comment

0 Comments
* Please Don't Spam Here. All the Comments are Reviewed by Admin.
Post a Comment (0)
Our website uses cookies to enhance your experience. Learn More
Accept !