Java Loops 1-Hacker Rank Solution

0

 

This is one of the easiest challenge in hacker rank regarding loops concept. In this challenge you will go through loops to solve this problem.Looping in programming languages is a feature which facilitates the execution of a set of instructions/functions repeatedly while some condition evaluates to true. While all the ways provide similar basic functionality, they differ in their syntax and condition checking time.

 

Challenge difficulty level: easy

Maximum score: 10

Task description:

Given an integer N print its first 10 multiples. Each multiple N * i(where 1 <=i <=10) should be printed on a new line in the form: N * i = result.

 

Input format

A single integer, N

Constraints

2<=N<=20

output format

print 10 lines of output each line i(where 1<=i<=10) contains the result of N * i in the  form:
n * i = result

Sample input

2

sample output

2 x 1 = 2
2 x 2 = 4
2 x 3 = 6
2 x 4 = 8
2 x 5 = 10
2 x 6 = 12
2 x 7 = 14
2 x 8 = 16
2 x 9 = 18
2 x 10 = 20

 

Solution 1:

 

import java.io.*;
import java.util.*;
import java.text.*;
import java.math.*;
import java.util.regex.*;

public class Solution {

    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int N = in.nextInt();
        if(N>=2||N<=20){
            for(int i=1;i<=10;i++){
                
                System.out.println(N+" x "+i+" = "+N*i );
            }
        }
    }
}

----------------------------------------------------------------------------------------

 

Solution 2

import java.io.*;
import java.util.*;
import java.text.*;
import java.math.*;
import java.util.regex.*;

public class Solution {

    public static void main(String[] args) {
        Scanner in = new Scanner(System.in);
        int N = in.nextInt();
        for(int i = 1; i <=10; i++)
        {
            System.out.println(N + " x "+i+" = "+i*N);
        }
    }
}
                   

Post a Comment

0 Comments
* Please Don't Spam Here. All the Comments are Reviewed by Admin.
Post a Comment (0)
Our website uses cookies to enhance your experience. Learn More
Accept !